Page tree
Skip to end of metadata
Go to start of metadata

This section:

This page:

New users should start with the Quick Start Guide document (see File > Help & Support > Help Documentation > Quick Start Guide). Then it is recommended to read the Tutorials to quickly familiarize yourself with basic program operation.


Design Structure

In HYPERSIM the term "design" refers to a complete, independent logical entity which is saved in a single file.

The following rules outline how a design is stored:

  • A single design is stored in a single file and no logical connections are made between designs. All information required to display and edit a design is stored in the design file.
  • A design never makes reference to external library files. When a library device is used, all information needed is read from the library and stored with the design. Changing the original library definition will not automatically update the design. More information on the relationship between symbol libraries and designs can be found in About Device Symbols.
  • When a design file is opened, the entire contents of the design are read into memory. This means that design sizes are limited by the available memory in your computer and increasing the memory allocated to the program will increase the size of the designs you can work with.
  • A number of user-settable parameters are stored with the design and affect the entire design when changed.

These include:

  • attribute and pin number text style settings
  • the attribute definition table
  • signal and device auto-naming settings
  • display options, such as crosshairs and printed page breaks
  • page reference format
  • hierarchy mode

In a hierarchical design (that is, one in which a symbol can represent a nested circuit block), all hierarchy levels are stored in a single file.

What is a Circuit?

A circuit in HYPERSIM® has the following characteristics:

  • A circuit can be drawn on one or more pages (up to 1000 in this version). You can elect to draw the entire circuit on a single page or divide it up functionally onto a number of pages.
  • Each page is viewed in a separate circuit window (tab) and any or all pages in a circuit can be displayed on the screen simultaneously.
  • A page is drawn on the screen as if it was a single piece of paper, although it may have to be broken up into a number of individual sheets of paper for printing or plotting.
  • Logical connections can be made between pages using a page connector device. Three versions of this device can be found in the built-in "Signal Routing" library. The "Page connector, control output/input" device is used to interconnect control signals across pages. The "Page connector, power signal" is used to interconnect power signals across pages. The “Page connector, bundle” is used to interconnect bundles across pages.

Types of Objects in a Circuit

An HYPERSIM® circuit is made up of five types of entities: devices, pins, signals, text objects and picture objects.

  • A device is an object having a symbol, signal connection points called "pins", and optional text attributes, internal circuit and simulation information. A device in HYPERSIM® can correspond to a physical device in a circuit, or it can represent a sub-circuit block or a pseudo-device, such as a page connector.
  • A pin is a connection point on a device. A pin is not an independent entity since it only exists as part of a device and cannot be created or deleted separately. However, pins can have attributes, pin numbers and other parameters that may be different from pin to pin on the same device. A bus (bundle) pin is a special type of pin that represents an arbitrary number of internal pins. The internal pins are not visible on the schematic but can still have the same logical properties as other pins.
  • A signal is a conductive path between devices. Signal connections can be made visually by drawing lines between device pins or logically by name.
  • A text object is used to place a title block or other notation on the diagram. Text can be typed and edited directly within HYPERSIM®, or can be created externally and pasted onto the diagram from the clipboard. Text objects are not associated with any other object and are not accessible through net or component lists. The attribute facilities should be used to associate text with specific devices or signals.
  • A picture object is used to place any graphics item imported from another program or the symbol editor tool via the clipboard. The Schematic tool cannot edit picture objects directly, other than moving, deleting and copying them whole. They can, however, be pasted into a symbol editor (or other application) window

How Design Templates Work

A design template is simply a normal design file that has its sheet size, attribute fields, hierarchy mode and other settings pre-defined for the application at hand. The simplest way to create a template may be to take an existing design that is set up the way you like it, delete all the circuit elements and extra pages out of it and save it in the appropriate template directory.
When you create a new design and select one of the template files listed, HYPERSIM® just reads the file in the normal way, then renames it "Circuit1" (or the next available number), and dissociates it from the original file so that it cannot accidentally be Saved on top of the template. In all other respects, creating a new design using the New command is the same as doing an Open on the template design. All the settings and contents of the design template file become part of the new design.
More information on "Design Templates" can be found in Design Templates.

HYPERSIM® File Types

HYPERSIM® deals with a number of different types of files. The most important type is the design file, which contains all the stored data of your schematics. Operations on design files are discussed in this chapter. 

DescriptionFile ExtensionMore Information
Design filesECFDesign structure
Symbol Library FilesCLFAbout device symbols
Report script filesRFM

HYPERSIM export script language files.

See Export script language

JavaScript filesJS

Scripting method in HYPERSIM based on JavaScript and HYPERSIM extensions to Java Script.

See JavaScript based scripting

Design and sheet template filesECFHow design templates work
Initialization filesINI

Top menus

The first ribbon is the File ribbon or File menu. The “>” character is used to denote sub menus. Each time a menu item (sub menu) is highlighted a tool tip appears for explaining its function.
The following bullets provide documentation links to the non-obvious options.



File > RevertRevert to the last saved version of this design. See Reverting to a Saved File.
File > OptionsVarious options for opening files and creating new designs.
File > Help & SupportTop Help and support section of HYPERSIM®.



Home > Clipboard > Paste SpecialPaste from the clipboard with options. See Paste Special.
Home > Tools > PointReturns to standard pointer.
Home > Tools > ZapSelects the Zap (delete) cursor. See Deleting a DeviceEditing a Signal Line and Hide a Visible Attribute Value. You can use ESC button or spacebar to return to the standard pointer.
Home > Tools > NameThis is the same as the Naming tool used for device attributes, pins and signal attributes. Selecting and clicking on a device, signal or pin gives access to the name attribute. Selecting and clicking on a visible attribute gives access to that attribute contents. This tool can be also used for editing text created with “Home>Draw Graphics>Text”.
Home > Tools > Draw SignalCreates signals (see Signals). For “Draw Bundle” see Bundles, for “Draw 3-phase Bus” (power system bus) see Signal Line Type and for Draw Phase A (B or C) see Signal Line Type.
Home > Tools > New BreakoutSee also Using Bundle Breakouts: New Breakout .
Home> Tools > Attribute ProbeDisplays attributes and information on the selected (clicked) object. See Displaying and Setting Device Information.
Home > Operations > PropertiesShows the properties of the selected device or of the circuit (when no selected device). This is the same as the Ctrl+I shortcut and this menu is available from actual object (device) right-click menu or circuit right-click menu.
Home > Operations > OrientationSets device orientation for the next device dragged in from a library. See also Placing and Editing Devices.
Home > Draw GraphicsVarious tools for drawing graphics objects on the schematic.
Home > Find > Quick FindSearch for entered object name (signal or device). Only partial information can be entered. You can use the Ctrl+G shortcut to zoom in on found signal or device.
Home > Find > Advanced FindOpens the Find tool tab. See Locating Circuit Objects with the Find Tool. You can use the Ctrl+G shortcut to zoom in on found signal or device.
Home > Find > Property BrowserOpens the Attribute Browser tool. See Property Browser.



Options > Design > PagesCreate, delete and modify circuit pages. See Adding, Deleting and Titling Circuit Pages.
Options > Design > Import Sheet InfoUsed to set the sheet border and background style. See also Importing Sheet Settings from another Design, Page or Template.
Options > Design > Sheet Size WizardView and change sheet size. See also Setting Sheet Sizes and Borders and Custom Sheet Size using Sheet Size Wizard.
Options > Design > Border WizardView and change border settings. See Border Wizard.
Options > Design > Design AttributesView and change design attributes. See Entering Design Attributes and Predefined Attribute Fields.
Options > Design > Define Attribute FieldsCreate or modify attribute field definitions. See Defining Attribute Fields.
Options > Naming OptionsVarious naming options for devices and signals. See Using the Auto-Naming FeaturesSignal Auto-Naming Options and Device Naming Options.
Options > Part Type > Update from LibUpdate the selected device from a library. See Update from Lib.
Options > Part Type > Save to LibSave the part definition of the selected device to a library. See Save to Lib.
Options > Part Type > Make Unique TypeMake a new part type definition for the selected device. See Make Unique Type.

Options > Subcircuit > Create Subcircuit Block

This is the top dialog for creating subcircuits. See Subcircuit creation methods.
Options > Subcircuit > New Port ConnectorCreates a port connector for the subcircuit interface pins. See also Creating Pseudo-Device Symbols.
Options > Subcircuit > Attach SubcircuitAttach a subcircuit to the selected symbol. See Attaching Subcircuit.
Options > Subcircuit > Detach SubcircuitDetach the subcircuit associated with the selected symbol, making it a separate design. See Detaching Subcircuit.
Options > Subcircuit > Discard SubcircuitDiscard the subcircuit associated with the selected symbol. See Discarding a Subcircuit.
Options > Subcircuit > Push IntoTo get into a selected subcircuit contents (same as Ctrl+Shift+I).
Options > Subcircuit > Pop UpClose the current subcircuit and go to the parent level (same as Ctrl+Shift+U).
Options > ExportExport operations
Options > Libraries> New PartOpens the Symbol Editor for creating a new part.
Options > Libraries> Library OperationsVarious library maintenance functions. See the section Working with Symbol Libraries for detailed information on this option.



View > Zoom > Go to SelectionSame as Ctrl+G, can be used for zooming onto a selection or a device found with find functions.
View > Zoom > PanAllows panning the circuit diagram. Same as holding Ctrl button and using left mouse button.
View > Zoom > RedrawRefresh the circuit drawing.
View > Panels > Parts LibraryShows or hides the Parts Palette. See Placing and Editing Devices.
View > Panels > ConsoleShows or hides the Console window.



This menu is scripted. It is created in the hyperworks.ini file and uses the HYPERSIM® scripting techniques for programming various tasks. You can open the scripts associated to each item and learn on script programming methods.

Design > Device Operations > Exclude DevicesExclude the selected devices from the Netlist. This command is similar to the Exclude/Include available from device right-click menu. The difference is that in this case it can act on one or more selected devices in the design. You can select entire circuit sections using the Shift and Ctrl keys while clicking on devices, or using a bounding box. See Device right-click menu.
Design > Device Operations > Include DevicesInclude the selected devices back into the Netlist. This command is similar to the Exclude/Include available from device right-click menu. There is no change if the selected devices are already included. The difference is that in this case it can act on one or more selected devices in the design. You can select entire circuit sections using the Shift and Ctrl keys while clicking on devices, or using a bounding box. See Device right-click menu.
Design > Device Operations > Show/HideCommands for showing or hiding various device attributes.
Design > Signal Operations > Signal ParametersAllows setting properties for selected signals. This is similar to the item “Signal Parameters” available from individual signal right-click menu (see Signal right-click menu). The difference is that you can now selected one or more signals and apply simultaneous changes.
Design > Signal Operations > Show HideCommands for showing or hiding signal names.
Design > Utilities > Define Global VariablesSee documentation link available after selecting this option. This option allows creating Global Variables to be used in various locations in HYPERSIM® mask scripts.
Design > Utilities > Run a scriptAllows to select and run a script on the current design.



This menu is created in the hyperworks.ini file.

HYPERSIM > Tools

HyperViewStarts HyperView application.
ScopeViewStarts ScopeView application.
TestViewStarts TestView application.
TargetOpens the Target Options window which lets you specify the target to use and the connection to what HYPERSIM® Engine.
I/OOpens the driver configuration window, which lets you manage the drivers in use.

HYPERSIM > Import

UCMImports a User Code Model (UCM) from a “def“ file.
SimulinkImports a Simulink model from a “mdl” file.
To LibraryImports an external model to a library.
NetworkImport an external network from these different formats; EDD, PSSe, PSCAD and ETRAN.

SIM > Sensors (see Sensors)

ClearWill remove all the sensors from the active model.
SaveSaves the sensor configuration of the active model in a file. You will have to specify a path and a file name if this is the first time you save this configuration.
Save AsSaves the sensor configuration of the active model in a specific file.
Open ConfigOpens and loads a sensor configuration for the active model. The previous configuration will be discarded.
Add to ConfigOpens and loads a sensor configuration for the active model. The previous configuration is kept (merged) with the new one.
Selected SummaryOpens the sensor configuration summary for the active model.

HYPERSIM > Network

AnalyzeAnalyzes the Network Topology.
Topology Analysis ReportOpens the Network Topology Analysis Report.
Load FlowOpens the Load Flow window.
Set Initial ConditionsStarts the Load Flow and loads the initial conditions.
Map TasksAllocates the tasks to available processors.
Task ManagerOpens the tasks manager tool to optimize and customize mapping.
Generate CodeGenerates the C code of the active model for a specific architecture in the directory specified in HYPERSIM>Simulation>Options.
NetlistOpens the Netlist window (see Netlist view).
Disable Breaker/FaultsIf there are any breakers and/or components with fault(s) in your model, this action will set their “General operation enable” to “Disable”.

HYPERSIM > Simulation

StartStarts the simulation on the target in HYPERSIM>Simulation>Options.
StopStops the running simulation.
OptionsOpens the Simulation options window where you can, for instance, set the Time Step and specify the target you would like to use for the active model (see Simulation ).
Data FolderOpens location of data logging file.

HYPERSIM Help

  • User Manual: Opens the HYPERSIM® user manual with the default program for PDF files.
  • No labels