Page tree
Skip to end of metadata
Go to start of metadata

When ScopeView opens, the Signals form and the Main window are present on the screen. The ScopeView Signals form shows on top of the main window in order to first choose a source of signals and a template to be displayed by the Main window. The Main window is described in this Chapter and the Signals form features are presented in Chapter 4.

Main Window

This section describes the major elements displayed in the main window of ScopeView. For a clearer understanding, it is subdivided in different areas, which are described in this chapter. These areas are the following:

  • Control buttons area.
  • Graphic page area.
  • Edit graphs area.
  • Information area.

Main Window Area


The two following figures give a brief description of each control button. The same shows a description that will appear when you leave your mouse cursor on the chosen button.

Icon related functions


Zoom options

Main Window Menus

FILE MENU

File menu

Open Data Source File...

Displays the window below. Select a file that was previously generated or select HYP for connecting to a HYPERSIM® model, TestView to connect to a TestView model. Clicking Load will load the data source of interest.

Data sources chooser window File and HYP tabs

NEW TEMPLATEThis item from the menu clears the graphic page area to let you create your own new template.
OPEN TEMPLATEAllows opening template used with another simulation session. Template files have.xml or.mod extension. The name of the template file will then appear at the top of the main window.


Open Template Window

SAVE TEMPLATEAllows saving a study set-up in a file for future use as a template or to help in setting up a new study in your current directory. The template is saved under ScopeView\templates\...
SAVE TEMPLATE AS...Allows to save a study set-up in a file for future use as a template or to help in setting up a new study in the directory of your choice.


Save Template As window

DELETE TEMPLATETo erase a template from your work station
EXPORT...

Used to transfer a result file in a different format to be used with simulation software or in a convenient format for visualization or printing purposes. Available formats are:

  • Comtrade (*.cfg)
  • Encapsulated Post Script (EPS) (*.eps);
  • Joint Photographic Expert Group (*.jpg)
  • MATLAB Binary (*.mat);
  • Portable Document Format (PDF) (*.pdf);
  • Portable Network Graphic (*.png);
  • Post Script (PS) (*.ps);
  • Text (tab separator) (*.txt).


PRINT...Print the actual window (results) displayed on screen. Allows selecting one of the printers installed on your workstation.
PRINT PREVIEW...Displays the actual graphical page area (results) before printing is released.
EXITQuits and closes ScopeView.

Edit Menu

Edit menu

CUTSelect a graph from the main window and click on this function to remove the graph from the graphic page area and put it on the clipboard.
COPYSelect the graph you want and click on this function to copy the graph on the clipboard. The selected graph remains on the graphic page area.
PASTEThis function displays the content of the clipboard on the actual graphic page area.
PASTE ON A NEW PAGEA variant from the Paste option. This function will create a new page and displays the content of the clipboard.
DELETERemove definitely the selected graph from graphic page area displayed.
SELECT ALLSelect all the graphs displayed on the graphic page area.
Another way to select all graphs is, move the cursor in the graphic page area then press the <CTRL> and <a> keys.
SELECT NONEDeselect all the graphs selected before.

View Menu

View menu

TOOLBARAllows user to show or hide the different menus from the Toolbar.
CANVAS FOOTERAllows showing or hiding the Edit Graph buttons at the lower left hand side of the ScopeView window.
ACQUISITION PARAMETERS...Allows selecting the starting time, sampling time length (duration) and, number of acquisitions to execute.
Synchronization (when ticked) specifies if a synchronization signal should be used during data acquisition2.
SHOW GRIDDisplays grid on all graphs on the graphic page area.
SHOW SELECTED GRAPHS ONLYSelect the graph(s) you want to display and click on this option.
If you select, for example, only one graph, the later will occupy the complete area of the graphic page area.
Unselected graphs are hidden not deleted.
SHOW ALL GRAPHSDisplays all the graphs including the ones that were hidden before.

Zoom Menu

Zoom Menu


The zoom options from the menu or the control buttons at the top of the main window allow viewing parts of graphs with a greater resolution in order to focus on selected parts of graphs.
The following types of zoom are available:

LZoom out last level
XZoom out last level X
YZoom out last level Y
BZoom out last level XY
Shift + XZoom out all levels X
Shift + YZoom out all lovels Y
RZoom out all levels
Moreover, ScopeView remembers the zooms made to revert to a previous state or an original state.

Graph Menu

Graph menu

SUPERIMPOSEDScopeView will display two or more traces in the same graph (depending how many signals you have selected).
UNDO SUPERIMPOSEDScopeView will display one signal per graph.
CURSORScopeView will display a Region cursor and a corresponding table. This type of cursor selects an area of interest of a graph and displays the coordinates and other information as per the table below.
To activate this feature, select the Cursor item; click your mouse to the beginning of the area you want then at the other end of the same area.


Region cursor table

Tracking Cursor Mode

  • Change the default cursor to a cross-hair cursor. The tracking cursor follows the graph curve and displays axis values at the lower left hand side of the graph.
  • To activate the cross-hair cursor function, first select the graph(s) of interest.
  • To select many graphs, press and hold the <CTRL> key then click on the graphs you want to select.
  • To select all the graphs, click on the Select All button at the lower left corner of the graphic page area.



  • No labels