Page tree
Skip to end of metadata
Go to start of metadata


SIGNALS WINDOW
GENERAL
It is necessary to configure a series of items before starting data acquisition. For example, you must select the signals to acquire, the corresponding mathematical operations to perform and to specify the number of acquisition. This is the preparation phase of the acquisition and this chapter describes the steps involved.
In the Signals Form below, four areas are accessible:

  • The command buttons area;
  • The available signals area;
  • Signal processing;
  • The selected signals area

Signal Form Window


SIGNALS FORM MENUS
In the following Figure, the File and Edit menus have the same functions as already described.

ScopeView - Signals form


VIEW MENU

View Menu


TOOL BAR
Allows user to show or hide the different menus from the Toolbar.

ADVANCE FUNCTION EDITOR
Allows user to display the advanced mathematical functions in editor mode. Detailed instruction on this mode is given later.

Signals form in Advance Function Editor mode


DATA SOURCE MENU

Data source menu


LOAD
Displays the Data Sources Chooser window and allows the user to load a particular plot file or signals from Hypersim® sensors.

Data sources chooser window

REPLACEDisplays the Data Sources Chooser window and allows the user to replace (delete the previous if any) and load a new file.
The Data Sources Chooser window displays a Replace button instead of the Load button.
RELOAD ALLReload the plot file already loaded when new sensors had been added in your HYPERSIM® simulation as per example.
REMOVE ALLRemove all the data sources already loaded.

GRAPH MENU

Graph menu


PLOT SIGNALS
Traces the graphs from the selected signals displayed in the selected signals area of the Signals window.
This menu item is the same command as the Plot icon on the tool bar or the Start button at the top of the window.

ACCESSIBLE AREAS
COMMAND BUTTONS
The first group of buttons at the left of the window are the usual functions from MS Window®.
The button gives you access to the mathematical functions. (The access is duplicated at the far right middle of the window).
The Start button tells ScopeView to trace the selected signals in the graphic page area.
AVAILABLE SIGNALS AREA
This area gives a detailed list of the available signals from the selected data source file displayed in the small window beside the Data Source button.
SELECTED SIGNALS AREA
This section displays the description of the selected signals to be plotted on each graphic page and the mathematical functions applied to the same signals.
SIGNAL PROCESSING
This area has a selection of functions modifying the graphic page area when ScopeView plots the selected signals.
The Signals form allows you to specify the signals to acquire and the corresponding mathematical operations to apply. The data source file is generated by the active simulation software, i.e. EMTP-RV.
You can also open a previously saved source file.
The Data Source... button reveals a menu (same menu as the one displayed by the Data Source item on the toolbar). From that menu, select the option you need.4.6.5. SIGNAL SELECTION

Data source menu


Data source chooser window


ScopeView can acquire data from many sources (Files of type). This section describes how to specify the data sources you want to use during a work session.

EMTPThe EMTP source allows importing signals saved previously in an .m, or .pl4, file generated by the EMTP simulation software.
MATLABThe MATLAB source is used to import signals saved previously in a .mat file generated by the MATLAB processing software.
The .mat file must contain a list of vectors with at least one of these vectors representing the abscissa (or time axis).
COMTRADEThe COMTRADE source allows importing signals saved previously in a .cfg file generated under the COMTRADE format.
DATALOGGERThe DATALOGGER source allows importing signals saved previously in a .oprec file generated under the OPAL-RT Data Record format.

To load previously saved sources, click on the file you want:

  • Select the signal type tab (EMTP, Matlab etc.);
  • Select the file format in accordance with the type of work station you are using, PC or UNIX
  • Click the button. (The Load button moves the files in the available signals area.).
  • Below the Loaded Data Source box is the Signal Type identification. From the pull-down list, select the type of signal you want to study. The list corresponds to the sensors installed in your simulation software or the usable Database.
  • It is possible to select files from the Loaded Data Source box (scroll-down-list) in order to display or delete them. It is possible to remove a single file or Remove All the files from the list and, finally the user can reload all or replace a file.
  • Remember, it is possible to study signals from two or more different sources at the same time.

SIGNAL PROCESSING
Below the Available Signals area, six cells and one button are present.
SIGNAL SELECTION MODE

  • Single: Any selected (mouse click) signal will move automatically to the Selected signals list.
  • Multiple: Click the signals you want then click the Add Signals button to add signals to the Selected Signals. Multiple selection is possible by clicking and holding the CTRL key.
  • The Add Signals button will show only when the multiple option is selected.

GRAPH CREATION

  • Normal: ScopeView will display one signal per graph.
  • Superimposed: ScopeView will display two or more traces in the same graph (depending how many signals you have selected.
X AXIS | Grid or LogScopeView will display, according to the ticked box, either a graph with or without a grid. The other option is used to display a linear or a logarithmic graph in the X axis.

Y AXIS | Grid or Log

ScopeView will display, according to the ticked box, either a graph with or without a grid. The other option is used to display a linear or a logarithmic graph in the Y axis.
PAGESelect the page number where you want to display the selected signal.
FUNCTION
  • From the pull-down list select the function you want to apply to the selected signal. The list contains simple functions (one signal per argument).
  • Advance functions are available by clicking one of the buttons.
  • When Multiple Signal Selection Mode is used, this button will add the selected signals to the list at the bottom part of the Selected Signal area.


SELECTED SIGNALS

This area shows all the selected signals and their description. The two right hand columns are used to display or not the result on the page of your choice.
By default the Signal column displays and confirms the selection of different signals.

  • To edit a signal, click on its cell, type in your changes and, hit <ENTER>. You must press <ENTER> to commit the changes or <ESC> to cancel. Either of these actions will return user to the default mode.
  • The Description column shows the signal description (often the same as the signal name under the Signal column.
  • The Show column, when “ticked” , the signal will be acquired and displayed in ScopeView.
  • In Page column, the number written under this column tells ScopeView on what page to display the result from that signal.
  • The numbered column at the far left is use to show the background edit menu. Right click on the line you want to edit.

SPLIT SCREEN OPTION
Scope View offers a split screen option to ease the multiple data source use. Simply click the mouse in the Signals area to see the background menu. You can split the area either horizontally or vertically. To revert to a single screen, click on Close View. Below is an example of horizontally split screen from the data sources loaded in two sections.

Signals form in split window option


REMOVING A SOURCE
The Remove button enables you to remove the current source or the Remove All button removes all the sources files from the scroll list.

To remove file (s) from the active list, display the source file you want to remove in the Loaded Data source file list;
Display the Data Source menu, and click on the Remove current data source item.
Or click on the Remove All button if desired.
If some formulas contain signals from a removed source, ScopeView displays a message asking to confirm this action. If you confirm, the formulas affected by the removal are automatically withdrawn from the list of formulas to evaluate.
REPLACE A SOURCE
The Replace button is used to change the characteristics of a source. This action is useful when you want to keep evaluating the same formulas, but with signals from a different source. The only restriction to replace a source is that the list of available signals should be the same.

  • To replace a source, in the Signal Form window, display the Data source menu;
  • Click on the source to change, select the Replace item.

ScopeView makes sure that the changes you make follow the replacement criteria. Otherwise, it refuses to execute the requested action.
INSERTING A FUNCTION
The Signals section allows you to insert a new signal or function to the list of Selected Signals to evaluate.
ADVANCE FUNCTION
To apply an advance function to a signal, click on the name of the signal;

  • Select the category of function you want to apply to a signal (or select “All” to see all the available functions;
  • In the Function Name drop list, select a function;
  • Click the Add Function button.

Signal form in advanced function option


SIMPLE FUNCTION
The Simple Function (far right of the ScopeView – Signals form) section allows you to specify the mathematical operations to apply to the signals you select in the list of available signals. You can also configure other characteristics such as:

  • abs: absolute value;
  • acos: arc cosine
  • asin: arc sine
  • atan: arc tangent
  • cos: cosine
  • densp: spectral density
  • deriv: derivative
  • integ: integral
  • i2T: integral Time reverse sequence
  • log: logarithm
  • log10: logarithm base 10
  • min: minimum
  • max: maximum
  • moy: average
  • rms: root mean square
  • sin: sine
  • sqrt: square root
  • tan: tangent

To apply a simple function to a signal, select the mathematical function to be applied to a signal using the menu related to the Function item.
Select a signal; Click Add Signals button.
LIST OF FORMULAS TO EVALUATE
The Selected Signals area contains the list of formulas to evaluate during the acquisition. Each line in the list describes a signal (and a function in some cases) to evaluate and specifies characteristics such as:

  • Description;
  • Show;
  • Page.

Initially, ScopeView displays the results in a graphic page corresponding to their appearance order in the list of Selected Signals. After a first acquisition, you can change the display order by displacing the graphs interactively.
The Selected Signal field specifies a formula to evaluate. A new formula can be generated automatically by ScopeView or built manually.
To insert automatically a new formula, click the selected source in the Data Source list;

  • Click on the signal you want in the list of Signals.
  • Select the processing to be applied from the pull-down list under Function to apply;
  • To edit manually a formula, click in the Formula field of the formula to edit.
  • Type the formula.
  • If this formula reuses a signal from another formula, you can then enter manually the identifier that was assigned to it by ScopeView. However, if the formula contains signals, which are not yet part of other formulas, you must insert them as follows to allow ScopeView to assign an identifier to each new signal:
  • Click on the selected source in the list of Data sources.
  • Click on the Multiple Signal Selection Mode and the function to be applied from the pull-down list under Simple Function to apply.
  • Click on the name of the chosen signal in the list of Signals.

ScopeView has a formula interpreter to evaluate complex formulas. This interpreter supports the following operators and functions:

  • Standard arithmetic operators (+, -, *, /, ** or ^, vs);
  • Assigning in one or many variables that can be reused by other formulas;
  • Standard mathematical functions (sine, cosine, logarithm, etc.);
  • Internal functions for spectral analysis (spectral density, frequency response, etc.);
  • TYRAN functions (calculation of module and phase for a symmetric, integral component, etc.);
  • External functions for signal processing (calculation of fundamental frequency, harmonics, digital filters, etc.).
DESCRIPTIONYou can specify in the Description field the description to identify the result of the formula during graphic display.
ScopeView automatically generates a default description when inserting a new formula. This description consists of an abbreviation representing the mathematical operation applied to the signal and the signal name (or signals) selected.
SHOWThe Show checkmark box specifies to ScopeView if it must display the formula result in a graph.
ScopeView automatically selects this item when a signal or a function is inserted from the list of Signals.
If you build manually a formula and you select this item, ScopeView will automatically initialize at 1 the Page field for the formula. You can change this page number if you wish.
PAGEThe Page field specifies the destination graphic page for the formula.

EDITING THE LIST OF FORMULAS

The list of signals can be edited to change the display order of the formulas or to delete them from the list.
You can edit the list of formulas either using the menu associated with the Edit menu, or the background menu associated with the scroll list. This menu allows executing the following commands:

  • To select one signal only, click in the far left column beside the required signal.
  • Select all: to select all the formulas.
  • Select none: to unselect all the formulas.
  • Cut: To cut selected formulas and save them in the buffer
  • Copy: To copy selected formulas in the buffer
  • Paste: To add to the list formulas from the buffer
  • Delete: To remove selected formulas without affecting the content of the buffer
CUTTo cut one or more formulas, move your cursor in the far left column and right click to display the background menu.
Click on Cut to cut and save in the buffer.
COPYTo copy one or more formulas, move your cursor in the far left column and right click to display the background menu.
Select the Copy option from the Edit menu.
PASTETo paste the content of the buffer, move your cursor in the far left column and right click to display the background menu.
Select paste the content of the buffer:
DELETETo delete one or more formulas, move your cursor in the far left column and right click to display the background menu.
Select the Delete option from the background menu.

TEMPLATE

In order to accelerate the configuration of repetitive and identical acquisitions from one session to another, ScopeView allows you to save and retrieve the information on the formulas to evaluate.
The following information is contained in a template acquisition:

  • List of sources used;
  • Acquisition numbers;
  • List of signals to acquire;
  • List of formulas to evaluate;
  • Editing information (number of columns, superimposition, zoom, etc.)

OPEN A TEMPLATE
You can load a previously saved template acquisition by selecting the button or the Open Template... item in the File menu. The software displays the form to select the file to open. The scroll list allows navigating in the file tree-structure.

Open template window


To load a template acquisition, click on the button or from the File menu click on Open Template...

ACQUISITION PARAMETERS
NUMBER OF ACQUISITION
The Number of Acquisition field specifies the number of acquisitions to be executed by ScopeView.
If the signals originate from acquisition units, it can be useful to have a number of acquisitions higher than one to see the evolution of the acquisition signals from one acquisition to another or to compute the average of the results obtained.

  • No labels