Page tree
Skip to end of metadata
Go to start of metadata


Design Templates

A design template is intended to be used as the source for a "File>New>Design" command. When a design template is selected in the "New Design" box, the design template file is opened and all the circuit data and settings it contains become the starting point for a new design.
The design template can be also used to program sheet settings.

Creating Design Templates

Do not modify the design templates provided with the software without copying them first! The user may wish to return to them later if the application changes. Also the new design templates are usually based on existing design templates.
In HYPERSIM®, a design template is simply a normal design file that has its sheet size, attribute fields, hierarchy mode and other settings pre-defined for the application at hand. The simplest way to create a template may be to take an existing design that is set up the way the user likes it, delete all the circuit elements and extra pages out of it and save it in the appropriate template directory.
When the user creates a new design using one of the template files listed, HYPERSIM® just reads the file in the normal way, then renames it "Circuit1" (or the next available number), and disassociates it from the original file so that it cannot accidentally be saved on top of the template. In all other respects, "New Design" is the same as doing an Open on the template design. All the settings and contents of the design template file become part of the new design.
Generally speaking a design template is a design with predefined attributes for the design, devices, signals and pins. It also has other settings, such as the sheet settings, and background and/or border objects. Specific scripting methods are named in attributes and provided for the targeted tasks.
It is important to specify the design attribute DesignType which is used for naming the template and can be used in scripting techniques.
In the default HYPERSIM® template the DesignType is HYPERSIM®. The template has a specific set of attributes designed for HYPERSIM® simulations.
The name of template file is any valid name. Once the template is created and saved, the user can access it and create designs based on the provided automation.

Creating a Title Block

In addition to setting attributes, a more basic and typical usage of templates is to create a title block. The title block is saved in the template and automatically appears in all designs based on the template.
HYPERSIM® has a number of features which can assist in creating title blocks which will contain information that is automatically updated. A simple title block can be created simply using the text feature by clicking the pencil cursor (Text Tool) in the desired location on the diagram. After the text has been typed, go back to the standard pointer mode and click on the text block to select it, then use Ctrl+I to open the Text Object Options box for setting various text options.
A more striking title block can be created using a graphic item imported from an external drawing program, such as the following:

Attributes can be used for automatically updating the various stamp fields. See Attribute Variables for learning how to show design attributes in text.

Sheet Templates

A sheet template is intended for use with the "Options>Design>Import Sheet Info" command and is used to set only the sheet border, title block, print setup and other settings related to the printable sheet.
There is no reason why a design template cannot be set up with all the sheet settings required for a specific design. This eliminates the need to ever refer to a sheet template. However, sheet templates can be used to apply different border styles and settings to different parts of a single design. In addition, separating out the sheet functions can reduce the number of design templates. The design template can be used to select the application type, attribute settings, script setup, etc. A sheet template can then be applied to customize the sheet border as a separate operation.

Setting Sheet Sizes and Borders

HYPERSIM® does not have any built-in knowledge of sheet sizes. Sheet border information can either be customized for each design or imported from an existing design file or template. This section describes the methods used for setting the sheet size and border for a schematic and the use of various options for adjusting the schematic border to the available output device.
HYPERSIM® supports very flexible use of plotters and printers for output on a variety of media. For this reason, there can be complex interactions between the drawing area allocated for each page and the way the schematic is presented when it is output on various kinds of output devices. Various settings allow:

  • Having the schematic border adjust automatically to the current printer page setup.
  • Having the schematic border retain a fixed logical size and have the printer scaling adjust automatically to fit the schematic on a single sheet.
  • Having the schematic border retain a fixed physical size and be broken into the required number of printed sheets for output.

The following information is considered to be part of the complete sheet definition:

  • The overall height and width of the drawing area.
  • The origin and spacing of the location grid.
  • The format of text used in the border.
  • Whether or not the border size should be linked to the current printer page setup.
  • Whether or not the page should auto-expand to multiple sheets.
  • Any text and picture objects marked as "border" items.

HYPERSIM® allows sheet size and border layouts to be set by one of two methods:

  • Importing an existing layout using the "Import Sheet Info" command from the “Options>Design”. This is the simplest method of setting the sheet size for a new design or template, but it assumes an existing design that has the desired settings.
  • Creating a custom layout using the "Drawing>Sheet Size Wizard" command. This command, and the associated text and picture capabilities, allows all aspects of the sheet size, drawing grid, border text style, title blocks and graphics to be set up to meet the user’s drawing standards.

Importing Sheet Settings from another Design, Page or Template

If another page in the current circuit, or an existing design or template file has the sheet size and border settings that the user wants, he can import those settings into the current design using the “Import Sheet Info” command. This command performs this sequence of operations:

  • Deletes all text and picture objects marked as "Border" items from the current page or design.
  • Copies all text and picture objects marked as "Border" items in the source design or page into the current design or page. The Border switch must be set individually for each border text or picture item using the Properties command from the right-click menu.
  • Copies the sheet and border settings (sheet width, grid settings, border text settings, etc.) from the source design or page to the current design or page.
  • Optionally copies the printer page setup from the source design to the current design.

Note these important points regarding this operation:

  • If the source for the import is a design file, only the items and settings on page 1 of the source design are imported. There is no provision for importing different settings from multiple pages.
  • The import operation does not affect any circuit items or attribute settings in the destination design.

Custom Sheet Size using Sheet Size Wizard

The "Sheet Size Wizard" command in the “Options>Design” toolbar gives the full control over the size of the drawing area that appears on the screen and how it is printed on the available output device. This section will describe the various options that are available.

Selecting Which Pages to Modify

If the design consists of only a single page and no hierarchy levels, the Wizard will immediately display the first page of sheet settings and this section can be skipped. If the design contains multiple pages or circuit blocks, this panel will be showed up:

Settings can be applied to individual pages or to the entire design.
If the first panel of the Wizard displays the Page Selection choice, then the user selects whether he wants to change only the current page or all pages and then clicks “Next”. If the selected range contains a variety of settings, the user will be warned that they will be overridden and will have to click Next again.

Selecting Fixed or Auto-Scaled Border

HYPERSIM® provides two general types of sheet size settings:


Scale border to match printer setupSelecting this option causes the current printer setup to be used to determine the sheet size. Any changes in print setup (using the Print Setup command in the File menu) will immediately affect the sheet border. This is the recommended setting for most cases as it provides a guaranteed match between the drawing area and the output device. The only disadvantage of using this setting is that the sheet size will change if printer’s settings changed. Most printers have slightly different printable areas, even on the same size paper.
Fixed border sizeSelecting this option causes fixed values to be used for the border size and position (as it appears on the screen), regardless of printer page setup. The advantage of this setting is that the sheet configuration will remain fixed regardless of changing output devices. The disadvantages are that the border size may not fit exactly to the aspect ratio of the printable area on the user’s printer. Choose the desired border scaling method and click Next.

Working with Scaled border Size

Once the user selects to scale the border to match the printer settings, the following options will be presented:

Single printed pageWhen this option is selected, the drawing border on the screen will always match the current printer page setup. Any change in printer setup will automatically be reflected in the sheet displayed on the screen. This is the simplest setting and recommended for most case.
Auto-expandThis setting also adjusts to match the printer page setup, but automatically expands to use multiple pages if the user draws outside the current border. This will allow assembling larger drawings by piecing together a number of smaller sheets.
AdvancedThe advanced setting is similar to Auto-expand, but allows specifying exactly how many sheets high and wide the user wants to display, plus it allows an additional scale factor to be applied to shrink or expand the output.

Working with Fixed border size

When you select the Fixed border size option and click Next, you will be presented with the sheet size controls:

Using these controls, the user can either select one of the standard sheet sizes listed, or enter any desired custom size.
These settings only determine the size that the sheet will appear on the screen and do not select a corresponding paper size for the default printer. Printer settings must be adjusted appropriately using the "Print Setup" command from the File menu.
The standard sizes that are listed here are determined by settings in the initialization file hyperworks.ini. These settings can be modified to suit the user’s requirements.
Enter the desired sheet size and click Next.

The next step in the Wizard allows choosing how the page will be adjusted for printing. Since “Fixed Size” option is selected, the program needs to know what to do if the visible page does not exactly match the printable area available on the paper.

Two general options are proposed:

Scale to fit printed pageIn this case, HYPERSIM® will scale the drawing to fit into the available printed area for the selected printer. The controls cans be used to specify that the drawing should be stretched onto multiple pieces of paper.
Fixed scale factorWith this setting active, the program will scale the drawing by a fixed amount (default 100%) for printing. This guarantees that the drawing will be a known size on paper, but may require that it be broken into multiple printed pages, depending on the settings.

Border Wizard

The Border Wizard command in the “Options>Design” toolbar allows setting these parameters:

  • The size and visibility of the default drawing border.
  • The layout of letter and numbers in the reference grid that is used to locate items on a sheet.
  • The size and visibility of the background grid.

This table summarizes the first page of Border Wizard controls and options:

Border OrientationThese switches determine the usage of letters and numbers for sheet grid references. This setting will affect the position displayed on Page Connectors, in the Pin List box and in report output.
Show default border on screenThis switch determines whether the default sheet border is drawn around the drawing area on the screen.
Print default borderThis switch determines whether the default sheet border is drawn in printed or PICT file output.
Border FontThis button displays the standard text style dialog box allowing the user to select the text style for the default border. This has no effect if both Print Default Border and Draw Default Border are off.
Border WidthThese switches allow the user to specify an exact width for the border or have it calculated automatically based on the text size setting.


When the user clicks Next, options for the layout of the major grid lines that are drawn in the background, will be presented. The major grid lines are the darker lines drawn in the background. The user can select later how many minor (lighter) grid lines are drawn in between the major lines.
Even if the user chooses not to display the drawing grid, these settings affect how the letter/number reference grid is calculated. This information is used and displayed by a number of reports and commands.

Specify the number of grid sectionsThis option allows the user to specify exactly how many grid sections are displayed with the controls. The size of the grid sections will be adjusted automatically to match any changes in sheet size.
Specify the size of the grid sectionsThis setting forces the grid sections to be a fixed size, regardless of changes in overall sheet size. In this case, the grid section width may not exactly divide into the sheet width, so the user must also specify how to handle any leftover space.
Show background grid on screenIf this switch is on, the background grid determined by the previous settings is drawn on the screen.
Print background gridThis switch determines whether the background grid is included in printed or graphics file output.
Number of minor grids per major gridThis number determines how many minor grid divisions are drawn per major division. The default value is 3, entering 1 in effect disables minor grid lines.

Creating Custom Sheet Border Graphics

Any picture or text objects can be made part of the sheet border.

To do this:

  • Select the object.
  • Choose the Properties command (or hit Ctrl+I) in the right-click menu.
  • Enable the "Make Background" and "Make Border" switches.
  • Click OK.

The object will now be treated as part of the sheet background.
See Background Objects and Border Objects for more information on background objects and how to select them.

Creating Multipage Templates

HYPERSIM® allows a circuit to be represented on multiple pages with logical connections between pages. When a new circuit is created, it is assumed to have a single page. A new page is added to the circuit by selecting the Pages command (in “Options>Design”) and clicking on the "New Page" button. The user can create a multipage template and reuse it for all new designs based on this template.
More information on using pages in designs can be found in Adding, Deleting and Titling Circuit Pages.

Sheet Border Setup for Multi-Page Designs

When a new page is added to a circuit, all border information and text and picture objects marked as "border" items are copied automatically from the preceding page (i.e. what was formerly the last page). For this reason, it is most convenient to set up the first page of the circuit with the desired border arrangement before adding other pages.
Borders on all pages in a design can be updated later if needed using the "Import Sheet Info" command.


  • No labels